CVE-2017-5898

Priority
Description
Integer overflow in the emulated_apdu_from_guest function in
usb/dev-smartcard-reader.c in Quick Emulator (Qemu), when built with the
CCID Card device emulator support, allows local users to cause a denial of
service (application crash) via a large Application Protocol Data Units
(APDU) unit.
Package
Source: qemu (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:released (2.0.0+dfsg-2ubuntu1.33)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:2.5+dfsg-5ubuntu10.11)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:2.8+dfsg-3ubuntu2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:2.8+dfsg-3ubuntu2)
Ubuntu 19.04 (Disco Dingo):not-affected (1:2.8+dfsg-3ubuntu2)
Ubuntu 19.10 (Eoan):not-affected (1:2.8+dfsg-3ubuntu2)
Patches:
Upstream:http://git.qemu-project.org/?p=qemu.git;a=commit;h=c7dfbf322595ded4e70b626bf83158a9f3807c6a
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needed
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-04-26 14:23:09 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)