CVE-2017-5884

Priority
Medium
Description
gtk-vnc before 0.7.0 does not properly check boundaries of
subrectangle-containing tiles, which allows remote servers to execute
arbitrary code via the src x, y coordinates in a crafted (1) rre, (2)
hextile, or (3) copyrect tile.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:released (0.6.0-3)
Ubuntu 14.04 LTS (Trusty Tahr):released (0.5.3-0ubuntu2.1)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (0.5.3-1.3ubuntu2.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (0.6.0-3)
Patches:
Upstream:https://git.gnome.org/browse/gtk-vnc/commit/?id=ea0386933214c9178aaea9f2f85049ea3fa3e14a
More Information

Updated: 2017-08-11 23:55:53 UTC (commit 13081)