CVE-2017-5337

Priority
Description
Multiple heap-based buffer overflows in the read_attribute function in
GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allow remote attackers to have
unspecified impact via a crafted OpenPGP certificate.
Assigned-to
mdeslaur
Notes
mdeslaurreproducer https://gitlab.com/gnutls/gnutls/commit/d949c6266ce64f5c2419f8c7cf4a196122fff9d7
https://gitlab.com/gnutls/gnutls/commit/e08b66b7cb4bc3f7ad56d081f0357ec1d39aa4ec
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (2.12.14-5ubuntu3.13)
Ubuntu 14.04 ESM (Trusty Tahr):released (2.12.23-12ubuntu2.6)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):released (3.4.10-4ubuntu1.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (3.5.6-4ubuntu3)
Patches:
Upstream:https://gitlab.com/gnutls/gnutls/commit/94fcf1645ea17223237aaf8d19132e004afddc1a
Upstream:https://gitlab.com/gnutls/gnutls/commit/6231a4a087f9fdbd5f5f274e80c7a71e3e45b9c8 (3.3)
More Information

Updated: 2020-07-28 20:01:48 UTC (commit d26b6ca9f5b3adb89bb036ce73ae7dab894935ec)