CVE-2017-5334

Priority
Medium
Description
Double free vulnerability in the gnutls_x509_ext_import_proxy function in
GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have
unspecified impact via crafted policy language information in an X.509
certificate with a Proxy Certificate Information extension.
References
Notes
 mdeslaur> looks like this was introduced by
 mdeslaur> https://gitlab.com/gnutls/gnutls/commit/2bd323f728d75c44a2d7398503178b75e5b63263
Assigned-to
mdeslaur
Package
Upstream:not-affected
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Package
Upstream:released (3.5.8-1)
Ubuntu 17.10 (Artful Aardvark):released (3.5.6-4ubuntu3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):released (3.4.10-4ubuntu1.2)
Ubuntu 17.04 (Zesty Zapus):released (3.5.6-4ubuntu3)
Patches:
Upstream:https://gitlab.com/gnutls/gnutls/commit/c5aaa488a3d6df712dc8dff23a049133cab5ec1b
Upstream:https://gitlab.com/gnutls/gnutls/commit/bbfd47d4bb6935b3eddae227deb9f340e2c1a69d (3.3)
More Information

Updated: 2017-10-17 19:14:40 UTC (commit 13537)