CVE-2017-5333

Priority
Description
Integer overflow in the extract_group_icon_cursor_resource function in
b/wrestool/extract.c in icoutils before 0.31.1 allows local users to cause
a denial of service (process crash) or execute arbitrary code via a crafted
executable file.
Notes
mdeslaurThis CVE is for "the separate vulnerability fixed by the
introduction of the "size >= sizeof(uint16_t)*2" test in
1a108713ac26215c7568353f6e02e727e6d4b24a"
Package
Upstream:released (0.31.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [0.29.1-2ubuntu0.1])
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [0.31.0-2+deb8u2build0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.31.1-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (0.31.1-1)
Ubuntu 20.04 (Focal Fossa):not-affected (0.31.1-1)
Patches:
Upstream:http://git.savannah.gnu.org/cgit/icoutils.git/commit/?id=1a108713ac26215c7568353f6e02e727e6d4b24a
More Information

Updated: 2020-03-18 21:25:15 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)