CVE-2017-3167

Priority
Medium
Description
In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the
ap_get_basic_auth_pw() by third-party modules outside of the authentication
phase may lead to authentication requirements being bypassed.
References
Assigned-to
mdeslaur
Package
Upstream:pending (2.2.33, 2.4.26)
Ubuntu 17.10 (Artful Aardvark):released (2.4.27-2ubuntu2)
Ubuntu 12.04 ESM (Precise Pangolin):released (2.2.22-1ubuntu1.12)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.4.7-1ubuntu4.16)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4.18-2ubuntu3.3)
Ubuntu 17.04 (Zesty Zapus):released (2.4.25-3ubuntu2.1)
Patches:
Upstream:https://www.apache.org/dist/httpd/patches/apply_to_2.2.32/CVE-2017-3167.patch
Upstream:https://github.com/apache/httpd/commit/78f0f0b6585f13ec1175c7020ee01cd0237fc1ba (2.4)
Upstream:https://github.com/apache/httpd/commit/7103baa2e70e37eeaf7847abaa6f3567ef2cdf73 (2.2)
More Information

Updated: 2017-08-11 23:55:45 UTC (commit 13081)