CVE-2017-2820

Priority
Medium
Description
An exploitable integer overflow vulnerability exists in the JPEG 2000 image
parsing functionality of freedesktop.org Poppler 0.53.0. A specially
crafted PDF file can lead to an integer overflow causing out of bounds
memory overwrite on the heap resulting in potential arbitrary code
execution. To trigger this vulnerability, a victim must open the malicious
PDF in an application using this library.
References
Notes
 mdeslaur> contrary to Debian, Ubuntu uses the internal JPEG 2000 library
 mdeslaur> as openjpeg has not been approved for main inclusion
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (0.24.5-2ubuntu4.5)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (0.41.0-0ubuntu1.2)
Ubuntu 16.10 (Yakkety Yak):released (0.44.0-3ubuntu2.1)
Ubuntu 17.04 (Zesty Zapus):released (0.48.0-2ubuntu2.1)
More Information

Updated: 2017-07-13 07:14:21 UTC (commit 12883)