CVE-2017-18922

Priority
Description
It was discovered that websockets.c in LibVNCServer prior to 0.9.12 did not
properly decode certain WebSocket frames. A malicious attacker could
exploit this by sending specially crafted WebSocket frames to a server,
causing a heap-based buffer overflow.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (0.9.10+dfsg-3ubuntu0.16.04.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (0.9.11+dfsg-1ubuntu1.2)
Ubuntu 20.04 LTS (Focal Fossa):released (0.9.12+dfsg-9ubuntu0.1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (0.9.13+dfsg-1)
Package
Source: veyon (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):needs-triage
Ubuntu 20.10 (Groovy Gorilla):needs-triage
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 20.04 LTS (Focal Fossa):needs-triage
Ubuntu 20.10 (Groovy Gorilla):needs-triage
More Information

Updated: 2020-07-28 18:43:54 UTC (commit 7b6828437fde0509248708fcdb5b0f7587b85bd1)