CVE-2017-18184

Priority
Description
An issue was discovered in QPDF before 7.0.0. There is a stack-based
out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
Assigned-to
mdeslaur
Notes
leosilvacouldn't reproduce in trusty or xenial. Also code in these
two releases are quite different from patch one.
Package
Source: qpdf (LP Ubuntu Debian)
Upstream:released (7.0.0-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [8.0.2-3~14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):released (8.0.2-3~16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Patches:
Upstream:https://github.com/qpdf/qpdf/commit/dea704f0ab7f625e1e7b3f9a1110b45b63157317
More Information

Updated: 2020-01-29 19:58:49 UTC (commit 768ceb2fdee6790d707d0f681e1b54916744af1e)