CVE-2017-18030

Priority
Description
The cirrus_invalidate_region function in hw/display/cirrus_vga.c in Qemu
allows local OS guest privileged users to cause a denial of service
(out-of-bounds array access and QEMU process crash) via vectors related to
negative pitch.
Package
Source: qemu (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:not-affected (2.0.0+dfsg-2ubuntu1.38)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:2.5+dfsg-5ubuntu10.20)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:2.11+dfsg-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:2.11+dfsg-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (1:2.11+dfsg-1ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (1:2.11+dfsg-1ubuntu1)
Patches:
Upstream:https://git.qemu.org/?p=qemu.git;a=commit;h=f153b563f8cf121aebf5a2fff5f0110faf58ccb3
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-04-26 14:22:07 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)