CVE-2017-17942

Priority
Description
In LibTIFF 4.0.9, there is a heap-based buffer over-read in the function
PackBitsEncode in tif_packbits.c.
Notes
mdeslaurprobably a dupe of CVE-2016-5319
as of 2019-10-16, no upstream fix
Package
Source: tiff (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):deferred (2019-10-16)
Ubuntu 14.04 ESM (Trusty Tahr):deferred (2019-10-16)
Ubuntu 16.04 LTS (Xenial Xerus):deferred (2019-10-16)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (4.0.7-1)
Ubuntu 19.04 (Disco Dingo):not-affected (4.0.7-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (4.0.7-1)
Ubuntu 20.04 (Focal Fossa):not-affected (4.0.7-1)
More Information

Updated: 2019-12-05 19:47:05 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)