CVE-2017-17669

Priority
Description
There is a heap-based buffer over-read in the
Exiv2::Internal::PngChunk::keyTXTChunk function of pngchunk_int.cpp in
Exiv2 0.26. A crafted PNG file will lead to a remote denial of service
attack.
Package
Source: exiv2 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (0.23-1ubuntu2.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.25-2.1ubuntu16.04.3)
Ubuntu 18.04 LTS (Bionic Beaver):released (0.25-3.1ubuntu0.18.04.2)
Ubuntu 18.10 (Cosmic Cuttlefish):released (0.25-4ubuntu0.1)
Ubuntu 19.04 (Disco Dingo):needed
Patches:
Upstream:https://github.com/Exiv2/exiv2/commit/06aa7ab69d0c4f3d14644bd84fc9d1346154430d
More Information

Updated: 2019-01-14 21:25:11 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)