CVE-2017-16844

Priority
High
Description
Heap-based buffer overflow in the loadbuf function in formisc.c in formail
in procmail 3.22 allows remote attackers to cause a denial of service
(application crash) or possibly execute arbitrary code via a crafted e-mail
message because of a hardcoded realloc size, a different vulnerability than
CVE-2014-3618.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:released (3.22-26)
Ubuntu 12.04 ESM (Precise Pangolin):released (3.22-19ubuntu0.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (3.22-21ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (3.22-25ubuntu0.16.04.1)
Ubuntu 17.04 (Zesty Zapus):released (3.22-25ubuntu0.17.04.1)
Ubuntu 17.10 (Artful Aardvark):released (3.22-25ubuntu0.17.10.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.22-26)
More Information

Updated: 2017-12-15 20:35:44 UTC (commit 13913)