CVE-2017-16820

Priority
Description
The csnmp_read_table function in snmp.c in the SNMP plugin in collectd
before 5.6.3 is susceptible to a double free in a certain error case, which
could lead to a crash (or potentially have other impact).
Ubuntu-Description
It was discovered that collectd failed to handle certain input. An attacker
could use this vulnerability to cause collectd to crash.
Package
Upstream:released (5.8.0-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (5.7.2-2ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (5.8.0-5.2)
Ubuntu 19.04 (Disco Dingo):not-affected (5.8.0-5.2)
Ubuntu 19.10 (Eoan):not-affected (5.8.0-5.2)
More Information

Updated: 2019-07-15 18:14:22 UTC (commit 421991a0db9d18995aaa37cf9728f6f902dc33be)