CVE-2017-15804

Priority
Description
The glob function in glob.c in the GNU C Library (aka glibc or libc6)
before 2.27 contains a buffer overflow during unescaping of user names with
the ~ operator.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):released (2.19-0ubuntu6.14)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Package
Source: glibc (LP Ubuntu Debian)
Upstream:released (2.27)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.23-0ubuntu10)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.27-3ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.27-3ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.27-3ubuntu1)
Patches:
Upstream:https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commit;h=a159b53fa059947cc2548e3b0d5bdcf7b9630ba8
More Information

Updated: 2019-01-14 21:24:34 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)