CVE-2017-15139

Priority
Description
A vulnerability was found in openstack-cinder releases up to and including
Queens, allowing newly created volumes in certain storage volume
configurations to contain previous data. It specifically affects ScaleIO
volumes using thin volumes and zero padding. This could lead to leakage of
sensitive information between tenants.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE (trusty was not-affected [code not present])
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):released (2:13.0.0~rc1-0ubuntu2)
Ubuntu 19.04 (Disco Dingo):released (2:13.0.0~rc1-0ubuntu2)
Ubuntu 19.10 (Eoan):released (2:13.0.0~rc1-0ubuntu2)
Patches:
Upstream:https://git.openstack.org/cgit/openstack/cinder/commit/?id=7feb62197d371ab7253dc86a34af6ff8b484b4df
More Information

Updated: 2019-04-26 14:20:19 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)