CVE-2017-15099 (retired)

Priority
Description
INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before 10.1,
9.6.x before 9.6.6, and 9.5.x before 9.5.10 disclose table contents that
the invoker lacks privilege to read. These exploits affect only tables
where the attacker lacks full read access but has both INSERT and UPDATE
privileges. Exploits bypass row level security policies and lack of SELECT
privilege.
Notes
sbeattieRLS and ON CONFLICT DO UPDATE introduced in 9.5
Package
Upstream:released (10.1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (10.1-1)
Package
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.5.10-0ubuntu0.16.04)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
More Information

Updated: 2019-10-09 07:59:19 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)