CVE-2017-14224

Priority
Description
A heap-based buffer overflow in WritePCXImage in coders/pcx.c in
ImageMagick 7.0.6-8 Q16 allows remote attackers to cause a denial of
service or code execution via a crafted file.
Notes
mdeslaur0316-CVE-2017-14224-Fix-heap-based-buffer-overflow-in-WritePCXImage.patch in wheezy
0251-CVE-2017-14224.patch in jessie
0103-CVE-2017-14224.patch in unstable
Package
Upstream:released (8:6.9.9.34+dfsg-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [8:6.7.7.10-6ubuntu3.11])
Ubuntu 16.04 LTS (Xenial Xerus):released (8:6.8.9.9-7ubuntu5.11)
Ubuntu 18.04 LTS (Bionic Beaver):released (8:6.9.7.4+dfsg-16ubuntu6.2)
Patches:
Upstream:https://github.com/ImageMagick/ImageMagick/commit/7f2d6fe34d695d3445e2d50937db5541a1b76bde
More Information

Updated: 2020-03-18 22:48:40 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)