CVE-2017-14130

Priority
Description
The _bfd_elf_parse_attributes function in elf-attrs.c in the Binary File
Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.29,
allows remote attackers to cause a denial of service (_bfd_elf_attr_strdup
heap-based buffer over-read and application crash) via a crafted ELF file.
Package
Upstream:released (2.29.1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Trusty/esm:needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.29.1-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.29.1-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.29.1-1ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (2.29.1-1ubuntu1)
Patches:
Upstream:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=2a143b99fc4a5094a9cf128f3184d8e6818c8229
Upstream:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=aceaeff8140af6ba50469e8b63d664cc91e5485b (v2.29)
More Information

Updated: 2019-04-26 14:19:57 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)