CVE-2017-13757

Priority
Description
The Binary File Descriptor (BFD) library (aka libbfd), as distributed in
GNU Binutils 2.29, does not validate the PLT section size, which allows
remote attackers to cause a denial of service (heap-based buffer over-read
and application crash) via a crafted ELF file, related to
elf_i386_get_synthetic_symtab in elf32-i386.c and
elf_x86_64_get_synthetic_symtab in elf64-x86-64.c.
Notes
 sbeattie> re-check to verify elf_i386_plt_sym_val() in older releases
Package
Upstream:released (2.29.1)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.29.1-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.29.1-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.29.1-1ubuntu1)
Patches:
Upstream:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=patch;h=90efb6422939ca031804266fba669f77c22a274a
Upstream:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=patch;h=bb0216e26681531bf967a6a3f1800789ade3693d (v2.29)
More Information

Updated: 2019-01-14 21:23:48 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)