CVE-2017-13728

Priority
Description
There is an infinite loop in the next_char function in comp_scan.c in
ncurses 6.0, related to libtic. A crafted input will lead to a remote
denial of service attack.
Notes
Package
Upstream:released (6.0+20170827-1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (6.1-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (6.1-1ubuntu1)
Ubuntu 19.10 (Eoan Ermine):not-affected (6.1-1ubuntu1)
Ubuntu 20.04 (Focal Fossa):not-affected (6.1-1ubuntu1)
Patches:
Other:ftp://ftp.invisible-island.net/ncurses/6.0/ncurses-6.0-20170826.patch.gz
More Information

Updated: 2019-12-05 19:44:13 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)