CVE-2017-13144

Priority
Description
In ImageMagick before 6.9.7-10, there is a crash (rather than a "width or
height exceeds limit" error report) if the image dimensions are too large,
as demonstrated by use of the mpc coder.
Notes
 mdeslaur> 0085-Avoid-a-crash-in-mpc-coder.patch in unstable
 mdeslaur> 0081-Avoid-a-crash-in-mpc-coder.patch in stretch
 mdeslaur> 0297-CVE-2017-13144-Fix-application-crash-if-image-dimensions-are-too-large.patch in wheezy
 mdeslaur> 0261-CVE-2017-13144.patch in jessie
 sbeattie> this fix introduced a regression in xenial and trusty
  (LP: #1793485) and was reverted for those releases in USN 3785-1
Package
Upstream:released (8:6.9.7.4+dfsg-13)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (8:6.9.7.4+dfsg-16ubuntu2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (8:6.9.7.4+dfsg-16ubuntu2)
Ubuntu 19.04 (Disco Dingo):not-affected (8:6.9.7.4+dfsg-16ubuntu2)
Ubuntu 19.10 (Eoan):not-affected (8:6.9.7.4+dfsg-16ubuntu2)
Patches:
Upstream:https://github.com/ImageMagick/ImageMagick/commit/9b580ad0564aefd9beeccbcbb8d62ccd05795a84
More Information

Updated: 2019-04-26 14:19:43 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)