CVE-2017-12967

Priority
Description
The getsym function in tekhex.c in the Binary File Descriptor (BFD) library
(aka libbfd), as distributed in GNU Binutils 2.29, allows remote attackers
to cause a denial of service (stack-based buffer over-read and application
crash) via a malformed tekhex binary.
Package
Upstream:released (2.29-5)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.29-5ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.29-5ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.29-5ubuntu1)
Patches:
Other:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=patch;h=de25939739ffe9a9ad7cec07a35bb2a1e430fe39
More Information

Updated: 2019-01-14 21:23:39 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)