CVE-2017-12955

Priority
Description
There is a heap-based buffer overflow in basicio.cpp of Exiv2 0.26. The
vulnerability causes an out-of-bounds write in
Exiv2::Image::printIFDStructure(), which may lead to remote denial of
service or possibly unspecified other impact.
Notes
ratliffon trusty, xenial, & zesty, exiv2 prints error message and exits cleanly
debianVulnerable code introduced after 0.25
Package
Source: exiv2 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [code not present])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (code not present)
Patches:
Upstream:https://github.com/Exiv2/exiv2/pull/120
More Information

Updated: 2020-09-10 05:36:38 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)