CVE-2017-12629

Priority
Description
Remote code execution occurs in Apache Solr before 7.1 with Apache Lucene
before 7.1 by exploiting XXE in conjunction with use of a Config API
add-listener command to reach the RunExecutableListener class.
Elasticsearch, although it uses Lucene, is NOT vulnerable to this. Note
that the XML external entity expansion vulnerability occurs in the XML
Query Parser which is available, by default, for any query request with
parameters deftype=xmlparser and can be exploited to upload malicious data
to the /upload request handler or as Blind XXE using ftp wrapper in order
to read arbitrary local files from the Solr server. Note also that the
second vulnerability relates to remote code execution using the
RunExecutableListener available on all affected versions of Solr.
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.6.2+dfsg-11)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (3.6.2+dfsg-11)
Ubuntu 19.04 (Disco Dingo):not-affected (3.6.2+dfsg-11)
More Information

Updated: 2019-03-26 11:21:32 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)