CVE-2017-12596 (retired)

Priority
Description
In OpenEXR 2.2.0, a crafted image causes a heap-based buffer over-read in
the hufDecode function in IlmImf/ImfHuf.cpp during exrmaketiled execution;
it may result in denial of service or possibly unspecified other impact.
Notes
mdeslaursame patch as CVE-2017-9110
Package
Upstream:released (1.6.1-6+deb7u1, 2.2.0-11.1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.2.0-10ubuntu2.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.2.0-11.1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.2.0-11.1ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (2.2.0-11.1ubuntu1)
Patches:
Upstream:https://github.com/openexr/openexr/commit/f09f5f26c1924c4f7e183428ca79c9881afaf53c (2.3)
Upstream:https://github.com/openexr/openexr/commit/49db4a4192482eec9c27669f75db144cf5434804 (2.2)
More Information

Updated: 2019-10-09 07:58:48 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)