CVE-2017-12562

Priority
Description
Heap-based Buffer Overflow in the psf_binheader_writef function in common.c
in libsndfile through 1.0.28 allows remote attackers to cause a denial of
service (application crash) or possibly have unspecified other impact.
Notes
 mdeslaur> debian's patch in 1.0.28-3 doesn't match the upsteam patch.
 mdeslaur> need to investigate further, looks like parts are missing.
 mdeslaur>
 mdeslaur> reproducer in upstream bug report.
Package
Upstream:released (1.0.28-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.0.28-3)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.0.28-3)
Ubuntu 19.04 (Disco Dingo):not-affected (1.0.28-3)
Ubuntu 19.10 (Eoan):not-affected (1.0.28-3)
Patches:
Upstream:https://github.com/erikd/libsndfile/commit/cf7a8182c2642c50f1cf90dddea9ce96a8bad2e8
More Information

Updated: 2019-04-26 14:19:29 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)