CVE-2017-12458

Priority
Medium
Description
The nlm_swap_auxiliary_headers_in function in bfd/nlmcode.h in the Binary
File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils
2.29 and earlier, allows remote attackers to cause an out of bounds heap
read via a crafted nlm file.
References
Notes
 sbeattie> same commit as CVE-2017-12455
Package
Upstream:released (2.29.1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.10 (Artful Aardvark):not-affected (2.29.1-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.29.1-1ubuntu1)
Patches:
Patch:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=patch;h=8bdf0be19d2777565a8b1c88347f65d6a4b8c5fc
Patch:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=patch;h=796337aa8ba0aa0397c07c264f82fe8eb9fd46e0 (v2.29)
More Information

Updated: 2018-02-02 09:14:17 UTC (commit 14120)