CVE-2017-12424

Priority
Description
In shadow before 4.5, the newusers tool could be made to manipulate
internal data structures in ways unintended by the authors. Malformed input
may lead to crashes (with a buffer overflow or other memory corruption) or
other unspecified behaviors. This crosses a privilege boundary in, for
example, certain web-hosting environments in which a Control Panel allows
an unprivileged user account to create subaccounts.
Package
Upstream:released (1:4.5-1)
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Trusty/esm:needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:4.5-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:4.5-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (1:4.5-1ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (1:4.5-1ubuntu1)
Patches:
Other:https://github.com/shadow-maint/shadow/commit/954e3d2e7113e9ac06632aee3c69b8d818cc8952
More Information

Updated: 2019-04-26 14:19:26 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)