CVE-2017-12196

Priority
Description
undertow before versions 1.4.18.SP1, 2.0.2.Final, 1.4.24.Final was found
vulnerable when using Digest authentication, the server does not ensure
that the value of URI in the Authorization header matches the URI in HTTP
request line. This allows the attacker to cause a MITM attack and access
the desired content on the server.
Notes
Package
Upstream:released (1.4.25-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1.4.25-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1.4.25-1)
More Information

Updated: 2020-10-24 06:37:50 UTC (commit 69e225d81a6ee3e2e014950178db797c5d4e5009)