CVE-2017-12087

Priority
Description
An exploitable heap overflow vulnerability exists in the tinysvcmdns
library version 2016-07-18. A specially crafted packet can make the library
overwrite an arbitrary amount of data on the heap with attacker controlled
values. An attacker needs send a dns packet to trigger this vulnerability.
Notes
Package
Upstream:released (3.1.4-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.1.4-1)
More Information

Updated: 2020-01-29 19:57:54 UTC (commit 768ceb2fdee6790d707d0f681e1b54916744af1e)