CVE-2017-12067

Priority
Description
Potrace 1.14 has a heap-based buffer over-read in the interpolate_cubic
function in mkbitmap.c.
Notes
 tyhicks> inkscape embeds libpotrace in Yakkety and earlier (LP: #1156664)
 mdeslaur> potrace in inkscape works on bitmaps already loaded, not
 mdeslaur> arbitrary images. Marking as not-affected for inkscape.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (code not present)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (code not present)
Ubuntu 19.04 (Disco Dingo):not-affected (code not present)
More Information

Updated: 2019-01-14 21:23:16 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)