CVE-2017-11628

Priority
Medium
Description
In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, a
stack-based buffer overflow in the zend_ini_do_op() function in
Zend/zend_ini_parser.c could cause a denial of service or potentially allow
executing code. NOTE: this is only relevant for PHP applications that
accept untrusted input (instead of the system's php.ini file) for the
parse_ini_string or parse_ini_file function, e.g., a web application for
syntax validation of php.ini directives.
References
Bugs
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.6.31)
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.22)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Patches:
Upstream:https://github.com/php/php-src/commit/5f8380d33e648964d2d5140f329cf2d4c443033c
Package
Upstream:released (7.1.7)
Ubuntu 17.10 (Artful Aardvark):released (7.1.8-1ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Patches:
Upstream:https://github.com/php/php-src/commit/05255749139b3686c8a6a58ee01131ac0047465e
Upstream:https://github.com/php/php-src/commit/0ba04f77379b5d277f5bd190c1542a0d91289978 (7.1 merge)
Package
Upstream:released (7.0.21)
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7.0.22-0ubuntu0.16.04.1)
Ubuntu 17.04 (Zesty Zapus):released (7.0.22-0ubuntu0.17.04.1)
Patches:
Upstream:https://github.com/php/php-src/commit/05255749139b3686c8a6a58ee01131ac0047465e
More Information

Updated: 2017-10-23 12:29:14 UTC (commit 13562)