CVE-2017-11102

Priority
Description
The ReadOneJNGImage function in coders/png.c in GraphicsMagick 1.3.26
allows remote attackers to cause a denial of service (application crash)
during JNG reading via a zero-length color_image data structure.
Notes
ebarrettoWatch out when applying the fix, it introduces a new vuln.
See CVE-2017-11139
Package
Upstream:released (1.3.26-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):released (1.3.23-1ubuntu0.2)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.3.26-2)
Ubuntu 19.04 (Disco Dingo):not-affected (1.3.26-2)
Ubuntu 19.10 (Eoan Ermine):not-affected (1.3.26-2)
Ubuntu 20.04 (Focal Fossa):not-affected (1.3.26-2)
More Information

Updated: 2019-12-05 19:40:13 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)