CVE-2017-10966 (retired)

Priority
Description
An issue was discovered in Irssi before 1.0.4. While updating the internal
nick list, Irssi could incorrectly use the GHashTable interface and free
the nick while updating it. This would then result in use-after-free
conditions on each access of the hash table.
Notes
 mdeslaur> same commit as CVE-2017-10965
Assigned-to
mdeslaur
Package
Source: irssi (LP Ubuntu Debian)
Upstream:released (1.0.4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (0.8.15-5ubuntu3.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.8.19-1ubuntu1.5)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.0.4-1ubuntu2)
Patches:
Upstream:https://github.com/irssi/irssi/commit/5e26325317c72a04c1610ad952974e206384d291
More Information

Updated: 2019-03-26 12:24:23 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)