CVE-2017-10683

Priority
Description
In mpg123 1.25.0, there is a heap-based buffer over-read in the
convert_latin1 function in libmpg123/id3.c. A crafted input will lead to a
remote denial of service attack.
Ubuntu-Description
It was discovered that mpg123 incorrectly handled certain media files.
An attacker could possibly use this issue to cause a denial of service or
other unspecified impact.
Notes
ratliffreproducer doesn't crash on trusty
Package
Upstream:released (1.25.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (1.16.0-1ubuntu1.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.22.4-1ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.25.8-1)
More Information

Updated: 2020-09-10 05:35:19 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)