CVE-2017-10140

Priority
Description
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x
before 3.2.2 might allow local users to gain privileges by leveraging
undocumented functionality in Berkeley DB 2.x and later, related to reading
settings from DB_CONFIG in the current directory.
Assigned-to
leosilva
Notes
sbeattiesee oss-sec for pam_ccreds example
Package
Source: db (LP Ubuntu Debian)
Upstream:released (5.1.29-9+deb8u1, 5.1.29-5+deb7u1)
Ubuntu 12.04 ESM (Precise Pangolin):released (5.1.25-11ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Package
Source: db4.8 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (4.8.30-11ubuntu1.1)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Package
Source: db5.3 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (5.3.28-3ubuntu3.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (5.3.28-11ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (5.3.28-13.1)
Ubuntu 19.10 (Eoan Ermine):released (5.3.28-13.1)
Patches:
Vendor:https://src.fedoraproject.org/rpms/libdb/raw/8047fa8580659fcae740c25e91b490539b8453eb/f/db-5.3.28-cwd-db_config.patch
Package
Source: db6.0 (LP Ubuntu Debian)
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Patches:
Upstream:https://patchwork.ozlabs.org/patch/866783/
More Information

Updated: 2020-01-29 19:57:38 UTC (commit 768ceb2fdee6790d707d0f681e1b54916744af1e)