CVE-2017-10078

Priority
Medium
Description
Vulnerability in the Java SE component of Oracle Java SE (subcomponent:
Scripting). The supported version that is affected is Java SE: 8u131.
Easily exploitable vulnerability allows low privileged attacker with
network access via multiple protocols to compromise Java SE. Successful
attacks of this vulnerability can result in unauthorized creation, deletion
or modification access to critical data or all Java SE accessible data as
well as unauthorized access to critical data or complete access to all Java
SE accessible data. Note: This vulnerability can be exploited through
sandboxed Java Web Start applications and sandboxed Java applets. It can
also be exploited by supplying data to APIs in the specified Component
without using sandboxed Java Web Start applications or sandboxed Java
applets, such as through a web service. CVSS 3.0 Base Score 8.1
(Confidentiality and Integrity impacts). CVSS Vector:
(CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N).
Ubuntu-Description
It was discovered that the JavaScript Scripting component of OpenJDK
incorrectly allowed access to Java APIs. An attacker could use this
to specially craft JavaScript code to bypass access restrictions.
References
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 17.04 (Zesty Zapus):needs-triage
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):not-affected (8u141-b15-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (8u131-b11-2ubuntu1.16.04.2)
Ubuntu 17.04 (Zesty Zapus):released (8u131-b11-2ubuntu1.17.04.2)
Patches:
Upstream:http://hg.openjdk.java.net/jdk8u/jdk8u/nashorn/rev/7c09d30a05f1
More Information

Updated: 2017-10-23 12:28:39 UTC (commit 13562)