CVE-2017-0902

Priority
Medium
Description
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking
vulnerability that allows a MITM attacker to force the RubyGems client to
download and install gems from a server that the attacker controls.
References
Bugs
Notes
 tyhicks> ruby{1.9.1,2.0,2.3} and jruby ship an embedded rubygems.
 leosilva> code not present in trusty for version 1.9.1
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.3.1-2~16.04.6)
Ubuntu 17.10 (Artful Aardvark):released (2.3.3-1ubuntu1.3)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.3.5-1ubuntu4)
Package
Source: jruby (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Patches:
Upstream:https://github.com/rubygems/rubygems/commit/8d91516fb7037ecfb27622f605dc40245e0f8d32
Upstream:https://bugs.ruby-lang.org/attachments/download/6691/rubygems-2613-ruby23.patch
Upstream:https://bugs.ruby-lang.org/attachments/download/6690/rubygems-2613-ruby22.patch
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
More Information

Updated: 2018-01-31 17:14:21 UTC (commit 14100)