CVE-2017-0630 (retired)

Priority
Description
An information disclosure vulnerability in the kernel trace subsystem could
enable a local malicious application to access data outside of its
permission levels. This issue is rated as Moderate because it first
requires compromising a privileged process. Product: Android. Versions:
Kernel-3.10, Kernel-3.18. Android ID: A-34277115.
Notes
 jdstrand> android kernels (flo, goldfish, grouper, maguro, mako and manta) are
  not supported on the Ubuntu Touch 14.10 and earlier preview kernels
 jdstrand> linux-lts-saucy no longer receives official support
 jdstrand> linux-lts-quantal no longer receives official support
 sbeattie> affects Nexus only devices
Package
Source: linux (LP Ubuntu Debian)
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (nexus devices only)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (nexus devices only)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected (nexus devices only))
Ubuntu 16.04 LTS (Xenial Xerus):DNE
This package is not directly supported by the Ubuntu Security Team
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (nexus devices only)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):ignored (abandoned)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (nexus devices only)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):ignored (abandoned)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (nexus devices only)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (nexus devices only)
Package
linux-krillin:not-affected (nexus devices only)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored [abandoned])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored [abandoned])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored [abandoned])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored [end-of-life])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
This package is not directly supported by the Ubuntu Security Team
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored [end-of-life])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored [end-of-life])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
This package is not directly supported by the Ubuntu Security Team
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (nexus devices only)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):ignored (abandoned)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored [abandoned])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (nexus devices only)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (nexus devices only)
Package
Upstream:not-affected (nexus devices only)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected (nexus devices only))
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
linux-vegetahd:not-affected (nexus devices only)
More Information

Updated: 2019-08-23 09:12:37 UTC (commit 436fd4ed4cf0038ddd382cb8649607ace163dda7)