CVE-2016-9955

Priority
Description
The SimpleSAML_XML_Validator class constructor in SimpleSAMLphp before
1.14.11 might allow remote attackers to spoof signatures on SAML 1
responses or possibly cause a denial of service (memory consumption) by
leveraging improper conversion of return values to boolean.
Notes
Package
Upstream:released (1.14.11-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 19.10 (Eoan Ermine):not-affected
Ubuntu 20.04 (Focal Fossa):not-affected
More Information

Updated: 2020-04-24 03:34:46 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)