CVE-2016-9935

Priority
Medium
Description
The php_wddx_push_element function in ext/wddx/wddx.c in PHP before 5.6.29
and 7.x before 7.0.14 allows remote attackers to cause a denial of service
(out-of-bounds read and memory corruption) or possibly have unspecified
other impact via an empty boolean element in a wddxPacket XML document.
References
Bugs
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.6.29)
Ubuntu 14.04 LTS (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.21)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=266ecb6d0a1ab5a37b4d652ca774a8adc4b06578
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=b04d60626de25edb06b6ecd6d7f5090b3dac0ecd
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=c89306ac52d9aff1eeec0441f1aff7e53c188234
Package
Upstream:released (7.0.14)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7.0.15-0ubuntu0.16.04.2)
Ubuntu 17.04 (Zesty Zapus):not-affected (7.0.14-2ubuntu1)
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=266ecb6d0a1ab5a37b4d652ca774a8adc4b06578
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=6292fe84d314bdb8504968084666a683983f8044
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=9b1430140a75698fd30b304d9bb488a2ce189750
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=c89306ac52d9aff1eeec0441f1aff7e53c188234
More Information

Updated: 2017-08-11 23:55:33 UTC (commit 13081)