CVE-2016-9933 (retired)

Priority
Description
Stack consumption vulnerability in the gdImageFillToBorder function in gd.c
in the GD Graphics Library (aka libgd) before 2.2.2, as used in PHP before
5.6.28 and 7.x before 7.0.13, allows remote attackers to cause a denial of
service (segmentation violation) via a crafted imagefilltoborder call that
triggers use of a negative color value.
Notes
 mdeslaur> php uses the system libgd2
Assigned-to
mdeslaur
Package
Upstream:released (2.2.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.1.0-3ubuntu0.6)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.1.1-4ubuntu0.16.04.6)
Patches:
Upstream:https://github.com/libgd/libgd/commit/77f619d48259383628c3ec4654b1ad578e9eb40e
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (uses system gd)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system gd)
More Information

Updated: 2019-03-26 12:23:44 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)