CVE-2016-9910

Priority
Description
The serializer in html5lib before 0.99999999 might allow remote attackers
to conduct cross-site scripting (XSS) attacks by leveraging mishandling of
special characters in attribute values, a different vulnerability than
CVE-2016-9909.
Notes
sbeattiesame commit as CVE-2016-9909
fix changes externally visible api from True|False boolean to
a ternary value, which will break users.
Package
Upstream:released (0.999999999-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.999999999-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (0.999999999-1)
Ubuntu 20.04 (Focal Fossa):not-affected (0.999999999-1)
Patches:
Other:https://github.com/html5lib/html5lib-python/commit/9b8d8eb5afbc066b7fac9390f5ec75e5e8a7cab7
More Information

Updated: 2020-04-24 03:34:43 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)