CVE-2016-9909

Priority
Description
The serializer in html5lib before 0.99999999 might allow remote attackers
to conduct cross-site scripting (XSS) attacks by leveraging mishandling of
the < (less than) character in attribute values.
Notes
 sbeattie> same commit as CVE-2016-9910
 sbeattie> fix changes externally visible api from True|False boolean to
  a ternary value, which will break users.
Package
Upstream:released (0.999999999-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.999999999-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (0.999999999-1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.999999999-1)
Patches:
Other:https://github.com/html5lib/html5lib-python/commit/9b8d8eb5afbc066b7fac9390f5ec75e5e8a7cab7
More Information

Updated: 2019-01-14 21:22:10 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)