CVE-2016-9586 (retired)

Priority
Description
curl before version 7.52.0 is vulnerable to a buffer overflow when doing a
large floating point output in libcurl's implementation of the printf()
functions. If there are any application that accepts a format string from
the outside without necessary input filtering, it could allow remote
attacks.
Assigned-to
mdeslaur
Package
Source: curl (LP Ubuntu Debian)
Upstream:released (7.52.0)
Ubuntu 12.04 ESM (Precise Pangolin):released (7.22.0-3ubuntu4.18)
Ubuntu 14.04 LTS (Trusty Tahr):released (7.35.0-1ubuntu2.11)
Ubuntu 16.04 LTS (Xenial Xerus):released (7.47.0-1ubuntu2.3)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (7.52.1-5ubuntu1)
Patches:
Upstream:https://github.com/curl/curl/commit/3ab3c16db6a5674f53cf23d56512a405fde0b2c9
Upstream:https://curl.haxx.se/CVE-2016-9586.patch
More Information

Updated: 2019-03-26 12:23:37 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)