CVE-2016-9189

Priority
Medium
Description
Pillow before 3.3.2 allows context-dependent attackers to obtain sensitive
information by using the "crafted image file" approach, related to an
"Integer Overflow" issue affecting the Image.core.map_buffer in map.c
component.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Package
Upstream:released (3.3.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.3.0-1ubuntu3.4)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (3.1.2-0ubuntu1.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (4.0.0-4)
Patches:
Upstream:https://github.com/python-pillow/Pillow/commit/c50ebe6459a131a1ea8ca531f10da616d3ceaa0f
Upstream:https://github.com/python-pillow/Pillow/commit/7d6f4104a114d106cd9502e040a78e793fb72393
Upstream:https://github.com/python-pillow/Pillow/commit/a662443b7f3fe394115d2eb9d71fb956b3848063
More Information

Updated: 2017-08-11 23:55:27 UTC (commit 13081)