CVE-2016-8859

Priority
Description
Multiple integer overflows in the TRE library and musl libc allow attackers
to cause memory corruption via a large number of (1) states or (2) tags,
which triggers an out-of-bounds write.
Package
Source: tre (LP Ubuntu Debian)
Upstream:released (0.8.0-3+deb7u1, 0.8.0-4+deb8u1, 0.8.0-5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):released ([0.8.0-3+deb7u1ubuntu1])
Ubuntu 16.04 LTS (Xenial Xerus):released (0.8.0-4+deb8u1build0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.8.0-6)
Ubuntu 19.04 (Disco Dingo):not-affected (0.8.0-6)
Ubuntu 19.10 (Eoan):not-affected (0.8.0-6)
More Information

Updated: 2019-09-19 14:33:48 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)