CVE-2016-8729

Priority
Description
An exploitable memory corruption vulnerability exists in the JBIG2 parser
of Artifex MuPDF 1.9. A specially crafted PDF can cause a negative number
to be passed to a memset resulting in memory corruption and potential code
execution. An attacker can specially craft a PDF and send to the victim to
trigger this vulnerability.
Notes
 mdeslaur> same fix as CVE-2016-9601.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needed
Trusty/esm:released (0.11+20120125-1ubuntu1.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.12+20150918-1ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.13-4.1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (0.13-4.1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.13-4.1)
Ubuntu 19.10 (Eoan):not-affected (0.13-4.1)
Patches:
Upstream:http://git.ghostscript.com/?p=jbig2dec.git;h=e698d5c11d27212aa1098bc5b1673a3378563092
Package
Source: mupdf (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE (trusty was not-affected [uses system jbig2dec])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system jbig2dec)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (uses system jbig2dec)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (uses system jbig2dec)
Ubuntu 19.04 (Disco Dingo):not-affected (uses system jbig2dec)
Ubuntu 19.10 (Eoan):not-affected (uses system jbig2dec)
More Information

Updated: 2019-04-26 14:18:12 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)