CVE-2016-8647

Priority
Description
An input validation vulnerability was found in Ansible's mysql_user module
before 2.2.1.0, which may fail to correctly change a password in certain
circumstances. Thus the previous password would still be active when it
should have been changed.
Notes
sbeattiefails on mysql forks percona 5.7 and newer, all mariadb
Package
Upstream:released (2.2.0.0-4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.5.1+dfsg-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.6.1+dfsg-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.6.1+dfsg-1)
Ubuntu 20.04 (Focal Fossa):not-affected (2.6.1+dfsg-1)
Patches:
Upstream:https://github.com/ansible/ansible-modules-core/pull/5388/commits/2dbbca65db5e88c7a75c75d9fa5a16d6a34f0dbc
More Information

Updated: 2019-12-05 19:34:18 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)